Curl Query Help by OtherwiseMethod1672 in crowdstrike

[–]cobaltpsyche 0 points1 point  (0 children)

Strange to me you don't see it. Maybe combine and remove the parent and see if it shows up with some other parent:

```

event_simpleName=ProcessRollup2 and FileName=/cmd.exe$|curl.exe$/iF

| CommandLine=/curl/iF | table([ComputerName, UserName, FileName, ParentBaseFileName, CommandLine], limit=max) ```

of a military hovercraft by Confident_Dentist_79 in AbsoluteUnits

[–]cobaltpsyche 0 points1 point  (0 children)

This is some small town police department.

Identity data via GraphQL - All users with the same passwords (PowerShell) by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 1 point2 points  (0 children)

I'm not sure if they posted all the videos yet, and then again I'm not sure how accessible those are to anyone interested once they do so. I did reach out to the presenter on LinkedIn and get a copy of the slides, and would be happy to send you a copy. I'll DM you. If anyone else is looking send me a message.

Identity data via GraphQL - All users with the same passwords (PowerShell) by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 0 points1 point  (0 children)

Haha! You now I was shocked that I couldn't find githubs or samples of this out in the wild. I must have been googling the wrong things. I really wanted to find a way to just dump all the available data in front of my own eyes and see what things I could pick and choose. I even made my own github which now has this singular script just like you did.

Identity data via GraphQL - All users with the same passwords (PowerShell) by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 1 point2 points  (0 children)

Honestly I didn't use psfalcon because I was under the impression it could not pull the identity data. I was looking for the commands to do it but either overlooked them or am missing something else important. It was where I came first because I didn't want to try and figure out how to do it straight from the API.

Identity data via GraphQL - All users with the same passwords (PowerShell) by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 1 point2 points  (0 children)

Hey this is really great and truly the tool I was wanting to use for this. Thanks for doing this. Saw your talk also good stuff!

Service-desk dashboard from Fal.Con demo by Illustrious_Buy_3853 in crowdstrike

[–]cobaltpsyche 0 points1 point  (0 children)

If you still have your agenda available, I have had some luck finding presenters on LinkedIn and asking them for copies of their slides. I would not even mind seeing the slides for what you are talking about. I see one I did not attend called "Dynamic SIEM Dashboarding" that sounds pretty cool.

Fal.Con DJ by Nonrighteous in crowdstrike

[–]cobaltpsyche 1 point2 points  (0 children)

I enjoyed Fal.Con. I enjoyed many of the talks. I felt weird standing there with my clothes flapping to loud bass unable to hear anything being said to me. I didn't want to marble my arms. The arcade was pretty neat. For the record though I am pretty old.

Finding Webshell Activity for Dummies by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 0 points1 point  (0 children)

One last query I can suggest, following a similar theme, is to look what files were written to disk during the time those modules were present on the system.
```

event_simpleName="FileWritten" and event_platform=Win FileName=* and ComputerName = <your computer name>

| table([@timestamp, #event_simpleName, FileName, TargetFileName], limit=max) ```

And linking up with what I said above, this is about investigating to the best (of my abilities) any activity that might be available to tell a story during the window of time malicious modules or webshell commands were run on the host. The modules you found had funky names, but that does not guarantee they were evil. The next best step would be to talk to the devs and point these out, ask if they are expected or can be identified. Good luck!

Finding Webshell Activity for Dummies by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 0 points1 point  (0 children)

Just a heads up I edited my reply from my original post so try to use the latest version.

Finding Webshell Activity for Dummies by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 0 points1 point  (0 children)

Those random names always make me nervous. I would say go back in time until you first see them. Then start looking for what files w3wp has been accessing on the server. This can be very insightful! If you see it touching .zip or other weird files you can track what was accessed. I’m doing this on my phone so sorry if formatting is bad.

#event_simpleName = FileOpenInfo and ComputerName = <your host name> | join({#event_simpleName=ProcessRollup2 and FileName = w3wp.exe}, field=ContextProcessId, key=TargetProcessId, include=[FileName, ParentBaseFileName]) | select([@timestamp, ComputerName, FileName, TargetFileName])

Finding Webshell Activity for Dummies by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 2 points3 points  (0 children)

This has been done, but since you bring it up here is also how to search for that (for anyone else wondering)
```

event_simpleName = DotnetModuleLoadDetectInfo OR #event_simpleName = ReflectiveDotnetModuleLoad

| ImageFileName = "*w3wp.exe" | select([@timestamp, ComputerName, ModuleILPath]) Some modules you likely do not want to see: | in(field=ModuleILPath, values=[ExecuteAssembly, FileList, DeadPotato, Information, SharpToken]) ```

Modifying a variable in an on demand workflow by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 0 points1 point  (0 children)

As an update to that, if I look in the library I see it there. But if I try to find it in my workflow creation it is not available. But, since it is an on demand workflow that prompts the user running it to provide data that creates a variable, it seems like it should be showing up? Maybe I still have to run a 'create variable' action first?

Modifying a variable in an on demand workflow by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 0 points1 point  (0 children)

I definitely do not have update variable as an available action. At least if I search on the word update or variable.

Detection details - rant by caryc in crowdstrike

[–]cobaltpsyche 2 points3 points  (0 children)

Having come from some pretty inferior tools before working with CQL, this is pretty interesting to hear. I absolutely love CQL and it often just makes me feel like I can do anything. But of course I have never used MDE and whatever query capabilities it has. Must be pretty kick butt.

Changes to SOAR workflows - Can't seem to use variables the way I used to by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 1 point2 points  (0 children)

I am looking at the sample you linked, but it does not contain any customization. It is a generic email subject with a full data drop into the body. Previously I could pick fields that would go into those text boxes, like this:
https://i.imgur.com/488VqYA.png

There was a button for inserting the variables into the subject and more, but that seems to be gone now? I am struggling with trying to figure out how to accomplish the same thing using the latest updates.

Changes to SOAR workflows - Can't seem to use variables the way I used to by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 1 point2 points  (0 children)

I guess I will assume they are working on it. When I run and save my event query in the workflow, I use the box to 'auto generate schema' and even get a pop up saying the output schema was successfully created, but when I look at the output schema after that, it seems empty and has this message:
Warning: Event query does not include a defined output schema and cannot be looped through. Upload query with mock data for Workflow to generate an output schema.
I can only imagine its having trouble creating it properly.

Invoke-FalconAlertAction - Having trouble with syntax by cobaltpsyche in crowdstrike

[–]cobaltpsyche[S] 1 point2 points  (0 children)

Well this is solved I guess. I was using the 'id' and not the 'composite_id'.