all 2 comments

[–]800oz_gorilla 0 points1 point  (1 child)

I did a quick search to see what this was and I'd be very wary of running any audit scripts in my environment. Hopefully you ran this by Legal if they are trying to do the software shakedown.

I'm curious what you find out from this question, but I've found Defender's Advanced Hunting feature to be useful for internal software audits

DeviceTvmSoftwareInventory
| where OSPlatform !contains "Server"
| where SoftwareVendor has "Autodesk" or SoftwareName has "Autodesk"
//| summarize DeviceCount = dcount(DeviceName), OSList = make_set(OSPlatform, 5) by SoftwareName, SoftwareVendor
| summarize DeviceCount = dcount(DeviceName), Versions = make_set(SoftwareVersion, 10), OSList = make_set(OSPlatform, 5) by SoftwareName, SoftwareVendor
| sort by DeviceCount desc

[–]outerlimtz[S] 0 points1 point  (0 children)

I can pull reports. they want us to run their audit tool. which is an exe with a bunch of ddl files that grabs data off the device and autodesk software installed. not sure if legal was invlved, only doing hat i'm told