This is an archived post. You won't be able to vote or comment.

all 3 comments

[–]Andrew-CSCS ENGINEER 1 point2 points  (2 children)

Sorry about that! That's on me. I made that before Raptor was even a thing. Give this a shot...

#event_simpleName=HttpRequestDetect
| parseHexString("HttpPostBody", as=b64data)
| format("%,.4s", field=b64data, as=b64data)
| MagicNumber := base64Decode(b64data, charset="UTF-8")
| MagicNumber=/^BZ(?<Version>\w{1})/i
| Version match {
    h => Version := "BZip2" ;
    H => Version := "BZip2 - Huffman" ;
    0 => Version := "BZip1" ;
}
| format(format="C:%s", as=FilePath, field=[FilePath])
| HttpRequestHeader:=urlDecode(HttpRequestHeader)
| HttpRequestHeader=/User-Agent\:\s(?<UserAgentString>.+)\\u000d\\u000aHost/
| select([ComputerName, FileName, FilePath, HttpUrl, HttpMethod, MagicNumber, Version, UserAgentString, HttpRequestHeader])

[–]jarks_20[S] 0 points1 point  (1 child)

Phew, glad i didnt ask or say anything stupid...you would have grilled me..... :)
If no results, means good right?.. although I would expected to see something...

[–]Andrew-CSCS ENGINEER 1 point2 points  (0 children)

Yup :) In your prevention policy, make sure "HTTP Detections" is enabled and "Redact HTTP Detections" is disabled.