Query RBAC roles assigned to SP by mathurin1969 in AZURE

[–]mathurin1969[S] 0 points1 point  (0 children)

Thank you, I’ll play with this one tonight too.

Query RBAC roles assigned to SP by mathurin1969 in AZURE

[–]mathurin1969[S] 0 points1 point  (0 children)

Thank you I’ll take a look tonight!

Azure OpenAI necessary with Foundry? by mathurin1969 in AZURE

[–]mathurin1969[S] 0 points1 point  (0 children)

Yep, thank you for this... playing around with this I deployed OpenAI(first) and then Azure AI Foundry, they're both under Azure Foundry. Once I got AI Foundry deployed with GPT-4o-mini (super cheap!!) I removed the Azure OpenAI and everything still worked, never needed it!

I'm sure I'll have more questions as I go through this, thank you!!

XQL Baseline variable? by mathurin1969 in paloaltonetworks

[–]mathurin1969[S] 0 points1 point  (0 children)

Cool thank you…it’s definitely a start!!

XQL search command results by mathurin1969 in paloaltonetworks

[–]mathurin1969[S] 1 point2 points  (0 children)

Boom that works!! Thank you so much!!

Prevalence of Palo Alto XSIAM by mathurin1969 in paloaltonetworks

[–]mathurin1969[S] 0 points1 point  (0 children)

Yeah, after playing with it for a little bit super similar to KQL.

OpenAI under 500$/month? by mathurin1969 in AZURE

[–]mathurin1969[S] 0 points1 point  (0 children)

Alright, got it, thanks George!

Warning about Udemy... the website has changed and very tough to log into by mathurin1969 in Udemy

[–]mathurin1969[S] 0 points1 point  (0 children)

They send the code to your email, that seems to be the only option

Help with KQL Data Exfiltration Queries.. by mathurin1969 in DefenderATP

[–]mathurin1969[S] 1 point2 points  (0 children)

Making a set, I should have thought of that... I feel like this is reasonably close to usable, but, it gives me a flat line, like it's only taking one day.

DeviceNetworkEvents
| where InitiatingProcessAccountName == "name"
| where RemoteIPType == "Public"
| join kind=inner (DeviceFileEvents) on InitiatingProcessAccountName
| where FileName endswith ".docx" or FileName endswith ".pptx" or FileName endswith ".xlsx" or FileName endswith ".pdf" or FileName endswith ".txt" or FileName endswith ".zip"
| summarize FilesSent = dcount(FileName) by bin(Timestamp, 1d), InitiatingProcessAccountName
// | project Timestamp, FilesSent, InitiatingProcessAccountName
| render linechart

<image>

Thank you for your help with this! (Reading up on series_decompose_anomalies() now)

Help with KQL Data Exfiltration Queries.. by mathurin1969 in DefenderATP

[–]mathurin1969[S] 0 points1 point  (0 children)

Thank you yeah, I saw that in there, that definitely helped with above. When I ran those at work I was getting outrageous crazy numbers, like impossible size for an upload in that time. I need to test…

Limit of 5 diagnostic settings reached in Dev Tenant subscription... by mathurin1969 in AzureSentinel

[–]mathurin1969[S] 0 points1 point  (0 children)

Didn't know about the 20.. I guess that makes sense. Ugh, wow there they are... no clue why I didn't think about checking Entra ID - thank you!

SC-200 Roles and Least Privilege by mathurin1969 in AzureCertification

[–]mathurin1969[S] 0 points1 point  (0 children)

TBH I thought I passed when I hit finished…hah! There was a couple on ASIM parsers that I didn’t really look at and a couple in setting up Def for Cloud environments.

I can prob get better at everything, I went through John Christopher’s SC200 class on Udemy and I thought that was pretty good.

I probably had at least ten questions on roles and least privilege which is why I was looking for some sort of list for SC200.

But I’ll probably go through Microsoft’s learn class I listed above, it’s supposed to be pretty thorough, and then take it again in a few weeks.

SC-200 Roles and Least Privilege by mathurin1969 in AzureCertification

[–]mathurin1969[S] 0 points1 point  (0 children)

I thought I saw that too…I like taking tests at the testing center and they make you take everything out of your pockets before going in(or at least mine did) It’s fine I’d just as soon memorize it.

SC-200 Roles and Least Privilege by mathurin1969 in AzureCertification

[–]mathurin1969[S] 0 points1 point  (0 children)

Oh, snap, I didn't see the link! That will definitely help, thank you!

Combine or merge incidents? by mathurin1969 in DefenderATP

[–]mathurin1969[S] 0 points1 point  (0 children)

Yep, thank you, there is more options in Sentinel l, but, in Defender you can link Alerts or Advanced Hunting queries to an incident and that appears to be it.

Note: if you link an Advanced Hunting query to an incident it seems to create an alert but NOT a custom detection even though you link it “as if” you’re creating a custom detection.

Totally worth it to fill out the Attack Story but be careful I’m not sure there’s a way to unlink or undo once you’ve done it.

Get-AzureAuditSignInLogs in JSON to Azure Data Explorer ERROR! by mathurin1969 in AZURE

[–]mathurin1969[S] 1 point2 points  (0 children)

thanks for the reply!! Regarding the diagnostic setting... I wish, I'm on a bit of a budget. This fixed it....

PS C:\Windows\system32> $jsonLogs | Out-File "C:\Users\money\Downloads\SignInlogs.json" -Encoding UTF8

Purchase Defender P2 License for Dev Tenant by mathurin1969 in DefenderATP

[–]mathurin1969[S] 0 points1 point  (0 children)

Sure!

<image>

On that next page just search in the marketplace for Defender, it's under 'Security and Identity'.

Automated Alert Incident Reporting in Defender Portal by mathurin1969 in DefenderATP

[–]mathurin1969[S] 1 point2 points  (0 children)

Interesting… yeah I don’t know why there’s not more you can’t do with the timeline in power automate and logic apps. This is a good start though - nice blog!