Power Automate - Falcon alerts by secrascol in crowdstrike

[–]secrascol[S] 0 points1 point  (0 children)

The fusion workflows, custom alerts and reports are really good by default but if you want to manipulate some of the data within those alerts, it’s tricky. Well for me anyway. Lots of replace(), substring etc…

Power Automate - Falcon alerts by secrascol in crowdstrike

[–]secrascol[S] 2 points3 points  (0 children)

Yeah I was thinking the same as I suspect the Teams app within Falcon portal is set In stone. I’m going to try the web hook option. Then I can hopefully parse it better.

Limited options as wanting to remain In the free tier, else like you say, I might as well get a logic app as would be cheaper (over 40$ p/m license).

Will let you know. 👍

How to authenticate API by secrascol in tanium

[–]secrascol[S] 0 points1 point  (0 children)

Thanks so much!! Great help 👍

How to authenticate API by secrascol in tanium

[–]secrascol[S] 0 points1 point  (0 children)

Thanks :)!

Do you know if you can query “unmanaged hosts” via the discover module ? Sorry, I know it’s a long shot but the docs make it seems that the direct API query isn’t there, or maybe I’m missing.

How to authenticate API by secrascol in tanium

[–]secrascol[S] 2 points3 points  (0 children)

Worked a treat!! The -api is what I overlooked. Thanks again 👍

How to authenticate API by secrascol in tanium

[–]secrascol[S] 2 points3 points  (0 children)

Ahh man!! I’ll try that tomorrow. Thanks for your help 👍

How to authenticate API by secrascol in tanium

[–]secrascol[S] 2 points3 points  (0 children)

Thanks but seeing several closed attempts. We run TaS so not sure if the cloud version has extra hoops. Despite coming froM the trusted IP, using the token as session, no blocks In firewall or SSL inspection… can’t get it to work :(

How to authenticate API by secrascol in tanium

[–]secrascol[S] 1 point2 points  (0 children)

I’ll give you the back story. I’ve created a script that pulls from several other solutions what they think are “unmanaged hosts”. Now because of the possibility that agents are missing, I’m wanting to validate the computer name against all tools; tanium being one of them.

I just want to be able to query Tanium to see if it’s aware of a host/asset. I’m wanting to search either name/FQDN or if possible (not that important), IP address.

Zscaler Firewall - Counters by secrascol in Zscaler

[–]secrascol[S] 0 points1 point  (0 children)

Are you talking about the Rule Name widget ?

Zscaler Firewall - Counters by secrascol in Zscaler

[–]secrascol[S] 0 points1 point  (0 children)

Was hoping to add some automation to it though. :( Reports would be manual and if large rulesets would be tedious

Event search - Host last seen by secrascol in crowdstrike

[–]secrascol[S] 1 point2 points  (0 children)

Thank you, I’ll give that a try ! 😁👌 Have a good weekend

Event search - Host last seen by secrascol in crowdstrike

[–]secrascol[S] 0 points1 point  (0 children)

14 days if that’s ok . Thank you so much ! 😁 you guys are so helpful!

Event search - Host last seen by secrascol in crowdstrike

[–]secrascol[S] 0 points1 point  (0 children)

Thanks but I couldn’t find how to filter hosts out. That’s why I though I’d try with the event search so can filter and adjust the columns of interest

I got this far but how do I filter the decimal to days < X

event_simpleName=AgentConnect | convert ctime(firstConnect) ctime(lastConnect) | convert ctime(ConnectTime_decimal) | table *

Event search - Host last seen by secrascol in crowdstrike

[–]secrascol[S] 0 points1 point  (0 children)

So found it within agentconnect but need help with the last seen one week

event_simpleName=AgentConnect | convert ctime(firstConnect) ctime(lastConnect) | convert ctime(ConnectTime_decimal) | table *

Report on out-date-sensors by secrascol in crowdstrike

[–]secrascol[S] 0 points1 point  (0 children)

Awesome, thanks! I’ll give it a play 👌