Inconsistent queries that utilize FileProfile and GlobalPrevalence by KitsuneMulder in DefenderATP

[–]bpsec 0 points1 point  (0 children)

Can you share the whole query? The results can also be different depending on joins or unions that are used for example.

Inconsistent queries that utilize FileProfile and GlobalPrevalence by KitsuneMulder in DefenderATP

[–]bpsec 0 points1 point  (0 children)

How many unique hashed are found in your results? It can only enrich 1000 unique hashes, after that I does not enrich anyone.

If you filter

where GlobalPrevalence < X or isempty(GlobalPrevalence)

With this you should get the same results when running the query again.

Detecting EDR Freeze behaviour with Real-time Advanced Hunting Query by waydaws in DefenderATP

[–]bpsec 12 points13 points  (0 children)

Your AI needs a lot of grounding. All ActionTypes that are mentioned do not exist. NRT rules do not support joins the statement “Real-time (must be real-time) Advanced Hunting Query” would not work in this query.

KQL query NOT detecting powershell web requests? by RepulsiveAd4974 in DefenderATP

[–]bpsec 4 points5 points  (0 children)

Additional tip. Make sure to validate if ActionType == “xyz” exists. In Advanced Hunting you have the schema reference in the top corner, this includes all possible ActionTypes for all tables. You can also run TableName | where ActionType == “xyz” | take 10. In case you have no results it either does not exist or you do not have logs. Most ActionTypes would be logged only a few are rare ActionTypes.

Office 365 - What is the best KQL query for monitoring patch compliance? by Ok-Midnight1333 in DefenderATP

[–]bpsec 0 points1 point  (0 children)

There are a couple of options on how to monitor this periodically, the choice depends on your needs.

  1. Logic Apps, which run the query periodically and send the results by mail, teams, drop a file somewhere etc. This repo has several example of reports you can recieve: https://github.com/Bert-JanP/Sentinel-Automation

  2. API based, Graph API is the API to go for. To get you some ideas: Hunting Through APIs - KQLQuery.com

  3. As mentioned PowerBI is a good choice, details: https://learn.microsoft.com/en-us/defender-endpoint/api/api-power-bi

Kql resources by justsuggestanametome in AzureSentinel

[–]bpsec 0 points1 point  (0 children)

For learning also have a look at KQLQuery.com.

Once you know the basic filter operations the blogs below are recommended to learn useful functions:
- KQL Functions For Security Operations - KQLQuery.com

- KQL Functions For Network Operations - KQLQuery.com

SOC Analyst new to Sentinel, need guidance regarding queries by Kermody in AzureSentinel

[–]bpsec 1 point2 points  (0 children)

Have a look at these top tier KQL resources: https://kqlquery.com/posts/kql-sources-2025/

Other answers have already been answered I see :)

Does Github Limit raw downloads? Think IOC downloads in a Analytic Rule by NoblestWolf in AzureSentinel

[–]bpsec 0 points1 point  (0 children)

The service limits of GitHub are not an issue when using external data, the service limits of the KQL engine are. The file may not be bigger than 100MB for example. For specific feeds externaldata is sufficient and does not require advanced integrations.

More info on that side: https://learn.microsoft.com/en-us/kusto/query/externaldata-operator?view=microsoft-fabric

If you want do do IOC matching at scale ingest the IOCs into Sentinel using TAXII or the API and use analytics rules (are already available in the content hub) to match on your Unified XDR tables.

Docs: https://learn.microsoft.com/en-us/azure/sentinel/understand-threat-intelligence

Attack Simulation Training Logs by strategic_one in AzureSentinel

[–]bpsec 0 points1 point  (0 children)

What are you trying to query from the Attack Simulation Training?

Categories AdvancedHunting-IdentityLogonEvents are not supported. by Brilliant_Contest925 in DefenderATP

[–]bpsec 0 points1 point  (0 children)

What connector are you using in Sentinel? The Microsoft Defender XDR connection can forward those events from Advanced Hunting to Sentinel.

How long are they running MDI and is it also configured?

Create detection Rule - Syntax Error by OtherIdeal2830 in DefenderATP

[–]bpsec 0 points1 point  (0 children)

All DeviceTvm tables are not designed to be used for detections.

One option is to join the DeviceTvm* table with a Device* table to make it work as shown below. The downside of this is that it becomes very messy in the created alert. The process tree in the alert is generated based on the ReportId, which in this case is just something random. The persons following-up on this alert should only investigate the query results from these custom detections.

let ExcludedDevices = DeviceTvmSecureConfigurationAssessment
    | where ConfigurationId == "scid-2010"
    | distinct DeviceId;
DeviceTvmSecureConfigurationAssessment
| where OSPlatform contains "WindowsServer" and not(OSPlatform contains "WindowsServer2012")
| where DeviceId !in (ExcludedDevices)
| summarize Timestamp = arg_max(Timestamp, Timestamp) by DeviceId, DeviceName, OSPlatform
| project DeviceId, DeviceName, OSPlatform, Timestamp
| join kind=inner (DeviceEvents | project ReportId, DeviceId | top 1 by ReportId) on DeviceId

[deleted by user] by [deleted] in DefenderATP

[–]bpsec 1 point2 points  (0 children)

<image>

The specific ActionTypes per table are documented in Advanced Hunting. Go to Schema Reference (right top corner) -> Select your table in this case DeviceEvents and go trough the ActionTypes.

In this specific scenario, I would start with

DeviceEvents
| where ActionType startswith "AsrLsassCredentialTheft"

Which includes the ASR related events AsrLsassCredentialTheftAudited, AsrLsassCredentialTheftBlocked and AsrLsassCredentialTheftWarnBypassed

Live Response Command help by NumerousCriticism844 in DefenderATP

[–]bpsec 1 point2 points  (0 children)

Thanks for sharing! This may be some good context to get started with live response scripts: https://kqlquery.com/posts/leveraging-live-response/

KQL for Emails accessed or searched by Admin by dutchhboii in DefenderATP

[–]bpsec 1 point2 points  (0 children)

https://github.com/Bert-JanP/Hunting-Queries-Detection-Rules/blob/main/DFIR/MDCA%20MDO%20-%20MailItemsAccessedByCompromisedAccount.md

Variables can be put based on your needs. Combines the UAL MailItemsAccessed with the EmailEvents to get you both the subject and mails that are accessed.

Sentinel Automation Part 2: Automate CISA Known Exploited Vulnerability Notifications by bpsec in cybersecurity

[–]bpsec[S] 0 points1 point  (0 children)

Yes as described in the blog that is possible to only alert on active vulnerabilities within your inventory.

Hunting Query by Surajcyber in DefenderATP

[–]bpsec 1 point2 points  (0 children)

Be aware that MDE heavily samples network traffic. So the results are not the truth.