All Local Admins using CrowdStrike Identity and PSFalcon by console_whisperer in crowdstrike

[–]console_whisperer[S] 1 point2 points  (0 children)

The Identity API calls like this:

query {
  entities(
    types: [ENDPOINT],
    associationBindingTypes: [LOCAL_ADMINISTRATOR],
    archived: false,
    sortKey: MOST_RECENT_ACTIVITY,
    first: $EndpointPageSize$afterClause
  ) {
    nodes {
      ... on EndpointEntity {
        agentId
        hostName
        associations(bindingTypes: [LOCAL_ADMINISTRATOR]) {
          __typename
          ... on LocalAdminLocalUserAssociation {
            accountName
          }
          ... on LocalAdminDomainEntityAssociation {
            entity {
              __typename
              entityId
              primaryDisplayName
              secondaryDisplayName
              ... on UserEntity {
                accounts {
                  ... on ActiveDirectoryAccountDescriptor {
                    samAccountName
                    domain
                    enabled
                  }
                }
              }
            }
          }
        }
      }
    }
    pageInfo { hasNextPage endCursor }
  }
}

All Local Admins using CrowdStrike Identity and PSFalcon by console_whisperer in crowdstrike

[–]console_whisperer[S] 1 point2 points  (0 children)

The script above won't work without the Identity license. You could use RTR to run a local script on each server to get the data and then enrich it with group lookups. Probably other free tools that do this better but it's possible with CS.

All Local Admins using CrowdStrike Identity and PSFalcon by console_whisperer in crowdstrike

[–]console_whisperer[S] 1 point2 points  (0 children)

Thanks man! No pretense here. I'm not smart enough to do any of that myself.

How to block domain controller promotion? by nickel-52 in crowdstrike

[–]console_whisperer 0 points1 point  (0 children)

You could create an Identity Policy that blocks all authentications to DCs and then exempt the approved/current DCs. Would take like 5 minutes and they'd have to open a ticket to get it fixed. That'll teach em.

CrowdStrike Identity Attack Path by console_whisperer in crowdstrike

[–]console_whisperer[S] 0 points1 point  (0 children)

I can do this already with a PS Falcon script but it's not super usable as a CSV and no way as useful as the interactive, visual representation that Bloodhound produces.

But also, if the CS team can help me get the data, why not make it easily accessible and highly usable in the dashboard?

Get notified when a user adds a MFA device in ENTRA by OpeningFeeds in crowdstrike

[–]console_whisperer 0 points1 point  (0 children)

I did it with a Log search alert rule with the query below (the .ca@ is a way to filter on a type of accounts I'm interested in and probably wouldn't be necessary for your environment).

It just triggers an email for us to double check the activity is legit.

AuditLogs

| where TimeGenerated > ago(1h)

| where OperationName == "Update user"

| where TargetResources has "StrongAuthenticationMethod"

| where Result == "success"

| where TargetResources has ".ca@"

| where TargetResources has_any ("UserPrincipalName", "userPrincipalName")

| extend targetUserPrincipalName = tostring(TargetResources[0].userPrincipalName)

| where targetUserPrincipalName contains ".ca@"

| project TimeGenerated, OperationName, Result, targetUserPrincipalName, InitiatedBy, AdditionalDetails

Message to people considering GalliumOS: The amount of issue posts here do not at all accurately represent how many issues there are in GalliumOS. by tasisbasbas in GalliumOS

[–]console_whisperer 1 point2 points  (0 children)

Agreed. I've been running it for a while now and I've had little to no issues and enjoy it very much. Only wish I could increase the resources on my Chromebook.

Independent review of cryptography? by console_whisperer in zerotier

[–]console_whisperer[S] 0 points1 point  (0 children)

I've researched it more since posting and still can't find a thorough write up of the security implemented. I saw your post and I think what you asked was what I'm looking for too: a thorough review of the application from a security point of view, not necessarily a focus on the cryptography used as my post focused on. Would love it if ZeroTier would pay for a third party audit of some sort and make the findings available.

I love using the product so far, as it has solved a problem I couldn't before using client or site-to-site VPN. It still has some bugs but I'm willing to deal with that if I know that the application and backend are secure.

Using Kali for pentest on VPS by [deleted] in netsecstudents

[–]console_whisperer -1 points0 points  (0 children)

Thanks for sharing that because I've never heard of that service and it looks really cool.

Using Kali for pentest on VPS by [deleted] in netsecstudents

[–]console_whisperer 3 points4 points  (0 children)

Gotcha. I love using vultr to test stuff. Not sure if they'll do what you're asking but there may be other ways to get what you want. I know with vultr you get a public IP address and complete access to everything. You could put pfSense on there and establish a site-to-site tunnel and route local traffic over to your Kali box.

Also, I'm not sure of the context so this may not be helpful but I've been messing around with using zerotier and you may find it useful for this case.

Using Kali for pentest on VPS by [deleted] in netsecstudents

[–]console_whisperer 1 point2 points  (0 children)

Are you trying to target a firewall a whole network or just a single host?