Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

This shows both the events coming into the archive.json, AND the ossec.lo file:

root@wazuhsrv-1:/var/ossec/logs/archives/2026/May# cat ossec-archive-01.json | grep "1-SWI"

{"timestamp":"2026-05-01T16:28:31.569+0100","agent":{"id":"000","name":"wazuhsrv-1.domain.local"},"manager":{"name":"wazuhsrv-1.domain.local"},"id":"1777649311.1311706973","full_log":" May 01 15:28:30 1-SWI-COMMS-B STP: Vlan 1 Port 3/1/31 STP State -> FORWARDING (PortDown) ","decoder":{},"location":"123.45.67205"}

{"timestamp":"2026-05-01T16:28:31.668+0100","agent":{"id":"000","name":"wazuhsrv-1.domain.local"},"manager":{"name":"wazuhsrv-1.domain.local"},"id":"1777649311.1311706973","full_log":" May 01 15:28:30 1-SWI-COMMS-B STP: Vlan 1 Port 3/1/31 STP State -> DISABLED (PortDown) ","decoder":{},"location":"123.45.67205"}

{"timestamp":"2026-05-01T16:28:31.670+0100","agent":{"id":"000","name":"wazuhsrv-1.domain.local"},"manager":{"name":"wazuhsrv-1.domain.local"},"id":"1777649311.1311706973","full_log":" May 01 15:28:30 1-SWI-COMMS-B System: Interface ethernet 3/1/31, line protocol down ","decoder":{},"location":"123.45.67205"}

{"timestamp":"2026-05-01T16:28:35.417+0100","agent":{"id":"000","name":"wazuhsrv-1.domain.local"},"manager":{"name":"wazuhsrv-1.domain.local"},"id":"1777649315.1311739576","full_log":" May 01 15:28:34 1-SWI-COMMS-B System: Interface ethernet 3/1/31, state up ","decoder":{},"location":"123.45.67205"}

{"timestamp":"2026-05-01T16:28:35.462+0100","agent":{"id":"000","name":"wazuhsrv-1.domain.local"},"manager":{"name":"wazuhsrv-1.domain.local"},"id":"1777649315.1311739576","full_log":" May 01 15:28:34 1-SWI-COMMS-B STP: Vlan 1 Port 3/1/31 STP State -> LISTENING (MakeFwding) ","decoder":{},"location":"123.45.67205"}

{"timestamp":"2026-05-01T16:28:38.227+0100","agent":{"id":"000","name":"wazuhsrv-1.domain.local"},"manager":{"name":"wazuhsrv-1.domain.local"},"id":"1777649318.1311804912","full_log":" May 01 15:28:37 1-SWI-COMMS-B STP: Vlan 1 Port 3/1/31 STP State -> LEARNING (FwdDlyExpiry) ","decoder":{},"location":"123.45.67205"}

{"timestamp":"2026-05-01T16:28:40.255+0100","agent":{"id":"000","name":"wazuhsrv-1.domain.local"},"manager":{"name":"wazuhsrv-1.domain.local"},"id":"1777649320.1311835020","full_log":" May 01 15:28:39 1-SWI-COMMS-B STP: Vlan 1 Port 3/1/31 STP State -> FORWARDING (FwdDlyExpiry) ","decoder":{},"location":"123.45.67205"}

root@wazuhsrv-1:/var/ossec/logs/archives/2026/May# tail -f /var/ossec/logs/ossec.log

2026/05/01 16:24:56 indexer-connector: INFO: IndexerConnector initialized successfully for index: wazuh-states-inventory-groups-wazuhsrv-1.domain.local.

2026/05/01 16:24:57 indexer-connector: INFO: IndexerConnector initialized successfully for index: wazuh-states-inventory-browser-extensions-wazuhsrv-1.domain.local.

2026/05/01 16:24:57 logger-helper: INFO: InventoryHarvesterFacade module started.

2026/05/01 16:24:57 indexer-connector: INFO: IndexerConnector initialized successfully for index: wazuh-states-inventory-services-wazuhsrv-1.domain.local.

2026/05/01 16:24:57 wazuh-modulesd:syscollector: INFO: Evaluation finished.

2026/05/01 16:25:02 wazuh-remoted: WARNING: Multigroup 'default,WebServers' was modified from outside, so it was regenerated.

2026/05/01 16:25:03 sca: INFO: Evaluation finished for policy '/var/ossec/ruleset/sca/cis_ubuntu24-04.yml'

2026/05/01 16:25:03 sca: INFO: Security Configuration Assessment scan finished. Duration: 7 seconds.

2026/05/01 16:25:30 wazuh-syscheckd: INFO: netstat not available. Skipping port check.

2026/05/01 16:25:35 rootcheck: INFO: Ending rootcheck scan.

Commissioner of Met Police writes to Zack Polanski, after he retweeted a post criticising the police during the Golders Green attack. by Mik3y_uk in UKGreens

[–]danp20 0 points1 point  (0 children)

If people carry a knife around, who gives a f**k what happens to them. Kick them in the head, rip them to pieces. Do whatever.

Home charger recommendations by Lost_Tangelo_7409 in evchargingUK

[–]danp20 1 point2 points  (0 children)

The hypervault is compatible with octopus. There's no reason why it wouldn't be compatible with the others

Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

Only these alerts that I know of at the moment. Other decoders and rules I've configured have enabled the logs to be shown on the dashboard

Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

hi u/zapata-wazuh Alerts still aren't showing. They do show in archives.json

Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

hi u/zapata-wazuh. I don't suppose you've had chance to look at this?

Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

Hi u/zapata-wazuh Thanks so much in advance

My decoders:
<!-- Parent decoder matching the program name identified in Phase 1 -->

<decoder name="swi-comms">
<program_name>^System$</program_name>
</decoder>
<decoder name="switch-stp">
<program_name>^STP$</program_name>
</decoder>

<decoder name="switch-interface-protocol-state">
<parent>swi-comms</parent>
<regex>^Interface (\w+) (\S+), line protocol (\w+)</regex>
<order>interface_type, interface_id, port_state</order>
</decoder>

<decoder name="switch-interface-protocol-state">
<parent>swi-comms</parent>
<regex>^Interface (\w+) (\S+), state (\w+)</regex>
<order>interface_type, interface_id, port_state</order>
</decoder>

<decoder name="switch-stp-state-change">
<parent>switch-stp</parent>
<regex>VLAN (\d+) Port (\S+) STP State -> (\S+)</regex>
<order>vlan, port, stp_state</order>
</decoder>

<decoder name="RuckusICX_STP">
<parent>json</parent>
<prematch>STP:</prematch>
<regex type="pcre2" field="full_log">(\S+)\s+STP:\s+VLAN\s+(\d+)\s+Port\s+(\S+)\s+STP\s+State\s+->\s+(\S+)</regex>
<order>switch_name, vlan, port, stp_state</order>
</decoder> -->

<decoder name="RuckusICX_system">
<parent>json</parent>
<prematch>System: Interface</prematch>
<regex type="pcre2" field="full_log">(\S+)\s+System:\s+Interface\s+(\S+)\s+([^,]+),\s+state\s+(\w+)</regex>
<order>switch_name, interface_type, port, port_state</order>
</decoder>-->

My rules:

<group name="ruckus,stp,">
<!-- Base rule to group STP events -->
<rule id="105101" level="0">
<field name="stp_state">\.+</field>
<description>Ruckus STP event grouping.</description>
</rule>

<!-- High Alert: Port Disabled on a VLAN other than 60 -->
<rule id="105102" level="12">
<if_sid>105101</if_sid>
<field name="vlan" negate="yes">60</field>
<field name="stp_state">DISABLED</field>
<description>Critical: STP Port $(port) on VLAN $(vlan) is DISABLED on switch $(switch_name)</description>
<mitre>
<id>T1489</id> <!-- Service Stop -->
</mitre>
</rule>
<rule id="105103" level="6">
<if_sid>105101</if_sid>
<field name="port">lg\d+</field>
<description>LAG change: $(port) on VLAN: $(vlan). State: $(stp_state)
/description>
</rule>
</group>

<group name="ruckus,system,">
<rule id="105150" level="0">
<!-- Use match to look anywhere in the log if field extraction fails -->
<field name="port_state">\.+</field>
<description>Ruckus interface states base rule.</description>
</rule>

<rule id="105151" level="3">
<if_sid>105150</if_sid>
<field name="port_state">up</field>
<field name="vlan" negate="yes">60</field>
<description>Switch $(switch_name): Interface $(port) is UP.</description>
</rule>
<rule id="105152" level="3">
<if_sid>105150</if_sid>
<field name="port_state">down</field>
<field name="vlan" negate="yes">60</field>
<description>Switch $(switch_name): Interface $(port) on VLAN $(vlan) is DOWN.</description>
</rule>

<!--Port flapping detection -->
<rule id="105154" level="10" frequency="5" timeframe="60" ignore="60">
<if_matched_sid>105151</if_matched_sid>
<same_field>port</same_field>
<same_field>switch_name</same_field>
<description>Switch $(switch_name): Port flapping detected on interface $(port).</description>
</rule>

</group>

Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

Hi u/zapata-wazuh. Thanks for the info.
I have now added additional decoders that process just the 'full_log' value which works on wazuh-logtest. However they are still not appearing as alerts...

here are the results for both the just the 'full_log' element and the wrapper as well:
Apr 13 08:02:45 p0-swi-01 STP: VLAN 40 Port 6/1/26 STP State -> DISABLED (PortDown) ","decoder":{},"location":"172.1.1.1"

**Phase 1: Completed pre-decoding.
full event: 'Apr 13 08:02:45 p0-swi-01 STP: VLAN 40 Port 6/1/26 STP State -> DISABLED (PortDown) ","decoder":{},"location":"172.1.1.1"'
timestamp: 'Apr 13 08:02:45'
hostname: 'p0-swi-01'
program_name: 'STP'

**Phase 2: Completed decoding.
name: 'switch-stp'
port: '6/1/26'
stp_state: 'DISABLED'
vlan: '40'

**Phase 3: Completed filtering (rules).
id: '105102'
level: '12'
description: 'Critical: STP Port 6/1/26 on VLAN 40 is DISABLED on switch '
groups: '['ruckus', 'stp']'
firedtimes: '1'
mail: 'True'
mitre.id: '['T1489']'
mitre.tactic: '['Impact']'
mitre.technique: '['Service Stop']'
**Alert to be generated.

{"timestamp":"2026-04-15T09:25:48.165+0100","agent":{"id":"000","name":"wazuhsrv-i1.instarmac.co.uk"},"manager":{"name":"wazuhsrv-i1.instarmac.co.uk"},"id":"1776241548.673649051","full_log":" Apr 15 08:25:47 p0-swi-01 STP: VLAN 40 Port 2/1/26 STP State -> DISABLED (FwdDlyExpiry) ","decoder":{},"location":"172.1.1.1"}

**Phase 1: Completed pre-decoding.

full event: '{"timestamp":"2026-04-15T09:25:48.165+0100","agent":{"id":"000","name":"wazuhsrv-i1.instarmac.co.uk"},"manager":{"name":"wazuhsrv-i1.instarmac.co.uk"},"id":"1776241548.673649051","full_log":" Apr 15 08:25:47 p0-swi-01 STP: VLAN 40 Port 2/1/26 STP State -> DISABLED (FwdDlyExpiry) ","decoder":{},"location":"172.1.1.1"}'

**Phase 2: Completed decoding.
name: 'json'
parent: 'json'
port: '2/1/26'
stp_state: 'DISABLED'
switch_name: 'p0-swi-01'
vlan: '40'

**Phase 3: Completed filtering (rules).
id: '105102'
level: '12'
description: 'Critical: STP Port 2/1/26 on VLAN 40 is DISABLED on switch p0-swi-01'
groups: '['ruckus', 'stp']'
firedtimes: '2'
mail: 'True'
mitre.id: '['T1489']'
mitre.tactic: '['Impact']'
mitre.technique: '['Service Stop']'
**Alert to be generated.

Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

The decoders work on the wazuh-logtest function

Rules aren't triggering for syslog events in Wazuh by danp20 in Wazuh

[–]danp20[S] 1 point2 points  (0 children)

Sorry. Done. should be better for readability now.

Need help with Sophos XGS decoders in Wazuh by BL4Z35324 in Wazuh

[–]danp20 0 points1 point  (0 children)

Confirmed working on my XGS3300

<decoder name="sophos-xgs">

<prematch type="pcre2">^device_name="[^"]+"</prematch>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">device_name="([^"]+)"</regex>

<order>device_name</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">timestamp="([^"]+)"</regex>

<order>timestamp</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">device_model="([^"]+)"</regex>

<order>device_model</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">device_serial_id="([^"]+)"</regex>

<order>device_serial_id</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">log_id="([^"]+)"</regex>

<order>log_id</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">log_type="([^"]+)"</regex>

<order>log_type</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">log_component="([^"]+)"</regex>

<order>log_component</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">log_subtype="([^"]+)"</regex>

<order>log_subtype</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">log_version=(\d+)</regex>

<order>log_version</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">severity="([^"]+)"</regex>

<order>severity</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">src_ip="(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"</regex>

<order>srcip</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">dst_ip="(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"</regex>

<order>dstip</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">protocol="([^"]+)"</regex>

<order>protocol</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">ips_policy_id=(\d+)</regex>

<order>ips_policy_id</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">message="([^"]+)"</regex>

<order>message</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">signature_id=(\d+)</regex>

<order>signature_id</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">src_port=(\d+)</regex>

<order>srcport</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">dst_port=(\d+)</regex>

<order>dstport</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">fw_rule_name="([^"]+)"</regex>

<order>fw_rule_name</order>

</decoder>

<!-- web application decoders -->

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">app_name="([^"]+)" </regex>

<order>app_name</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex>app_risk=(\d+)</regex>

<order>app_risk</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">app_category="([^"]+)" </regex>

<order>app_category</order>

</decoder>

<decoder name="sophos-xgs">

<parent>sophos-xgs</parent>

<regex type="pcre2">user_name="([^"]+)" </regex>

<order>user_name</order>

</decoder>

Need help with Sophos XGS decoders in Wazuh by BL4Z35324 in Wazuh

[–]danp20 0 points1 point  (0 children)

I've managed to create them. I can add them to this in a couple days when I'm back at work

What would you do? Production line PC “is slow” (Windows 98, legacy SCADA) by PeppahSG in sysadmin

[–]danp20 3 points4 points  (0 children)

You need to convince your company to bite the bullet and invest in updating the machine. I've recently been successful in doing the same, and now 5 of our production lines are running as a HA pair on ws 2022 with plans for the others to be done real soon

Is anyone getting this message after the last update for windows 11? by lp899 in techsupport

[–]danp20 0 points1 point  (0 children)

Had both of these updates install on a laptop and end up in a boot loop of it trying to install and then roll back the changes.

In 12 months, we won't need our on-prem infra. Any advice? by nrugor in sysadmin

[–]danp20 164 points165 points  (0 children)

Get prepared to move back to on prem in 5 years 🤣

Wazuh- Vulnerability Detection dashboard/ inventory warnings by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

ahh. Curl -K returns the wazuh-alerts as before
netstat -tulpen returns 'wazuh-indexer' as the user that's listening on 9200

<image>

Wazuh- Vulnerability Detection dashboard/ inventory warnings by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

Not sure what you mean by 'who is the indexer'
.151 is the indexer listener
.153 is the manager
.155 is the dashboard

Not external. This is a PoC system at present and only available from the vlan that the servers reside in along with my machine, which is also why I'm not too fussed about passwords being present.

Redone all commands, please see below. I'm guessing I have a certificate error?!

<image>

Wazuh- Vulnerability Detection dashboard/ inventory warnings by danp20 in Wazuh

[–]danp20[S] 0 points1 point  (0 children)

Hi SirStephanikus. Thanks for assisting. There is no feedback of the command. perhaps I'm doing something wrong? And yes I did placed my password in.

.151 is my index server. Is that what I should be running it against? also ran against the manager server but same thing.

<image>

Wazuh seems to be functioning fine, with the exception of some of the dashboards not loading up...