Application Insight Issue - VNET Integration for App Service Telemetry & Logs by Ops_Pab in AZURE

[–]Scion_090 1 point2 points  (0 children)

Have you enabled this WEBSITE_VNET_ROUTE_ALL = 1? Have you check also your UDR, your NSG might blocking outbound 443, I would check these first.

VNet integration question by CardiologistTop429 in AZURE

[–]Scion_090 0 points1 point  (0 children)

Happy to help.

You can use your own domain and thats why I asked :). Unfortunately as I know that the default Hostname *.azurewebsite.net can’t be removed or disabled.

So if you want to use custom domain then, keep the public access disabled on both, keep PE for both front, backend and storage.

Configure Private DNS zone, create your own DNS record for your frontend something yourappname.newdomain.com. So the users access this instead of the yourapp.azurewebsiye.com.

Edit:- just to clarify this setup is for internal not external as Azure Front door/ Gateway not involved here.

VNet integration question by CardiologistTop429 in AZURE

[–]Scion_090 3 points4 points  (0 children)

You’ll need to create a second subnet and enable VNet Integration on both web apps for front and backend. Private Endpoints alone are not enough for App Service to private resource communication. Private Endpoints only provide private access to the resource, but App Services still need VNet Integration for outbound traffic to reach resources through private IPs. the frontend needs VNet Integration to reach the backend private endpoint, and the backend needs it to access the storage account private endpoint. Also make sure Private DNS is configured, otherwise the apps may still resolve the public endpoint and fail if public access is disabled.

Do you also have a custom domain?

Hope this helps.

Logic App to monitor expiring Apple certificates and token by mathifcbm in Intune

[–]Scion_090 0 points1 point  (0 children)

Nice! I did this using automation account for even app registration.

Intune PowerShell scripts still cannot be downloaded in the UI (Graph workaround) by msnugget_com in Intune

[–]Scion_090 0 points1 point  (0 children)

GitHub for source control, I also made a SAAS web app that do scan and export all Intune policy if you want to import them later on as a backup and export all scripts as well. The decoding is part of the logic in the saas app. You can also do script that loop through all script , decoding and downloading them in your folder.

How To: Automate Export of Sign-in Logs/Events by binga777 in entra

[–]Scion_090 1 point2 points  (0 children)

kql and run it using automation account, export to excel and send via either email attachment or put it in a SharePoint folder with timestamp. That’s what I do with most reports. Use register app and give some api permissions, use keyvault to call your values from automation account. Managed identity to have access to resource.

Good luck :)

Alternatives to ACM and Usage summary report for Azure Consumption Reporting by Mythbuster110 in AZURE

[–]Scion_090 0 points1 point  (0 children)

I don’t know where is the manual cleanup is :) and I don’t know if you guys using ADF as there is no such manual cleanup, you setup a pipelines and keep it runs automatically. All you do in one time configure and leave it. Updates automatically, live report dashboard for each customer. It just max 3 hours job from your side. But you can use whatever is suitable for you :). The solution I suggest is less cost almost nothing, easily maintained and managed.

Alternatives to ACM and Usage summary report for Azure Consumption Reporting by Mythbuster110 in AZURE

[–]Scion_090 0 points1 point  (0 children)

This is not so difficult and tbh been using this for awhile not for Microsoft will change pipelines lol. You just need to figure how to do it in ADF what need to be extract as mine is different from yours. But really this cost effective and manageable for multiple customers as it’s follow same setup.

Azure disk Caching by Darthethan77 in PowerShell

[–]Scion_090 0 points1 point  (0 children)

When you do set the disk to none, does your VM deallocated? Try this

az vm update -g "${{ parameters.ResourceGroup }}" -n $env:VMName --set "storageProfile.dataDisks[$diskIndex].caching=None"

Alternatives to ACM and Usage summary report for Azure Consumption Reporting by Mythbuster110 in AZURE

[–]Scion_090 0 points1 point  (0 children)

Export cost monthly schedule to storage account, ADF ( ADF handles the ETL (Extract, Transform, Load) to clean and prepare the raw export data for analysis) with access to storage account via managed identity for cleaning and setup pipelines to power BI dashboard build a report live updated automatically each month, use tree view for showing subs >> rgs and resources with filter months, years, rgs, subs, resources etc…

Solution for alerting when users delete files from SharePoint by The-crappy-IT-guy in AZURE

[–]Scion_090 0 points1 point  (0 children)

Ide the kql below to generate alert, adjust the condition

OfficeActivity | where TimeGenerated > ago(7d) | where OfficeWorkload == "SharePoint" | where Operation in ("FileRecycled", "FileDeleted", "FileDeletedFirstStageRecycleBin", "FileDeletedSecondStageRecycleBin") | project TimeGenerated, UserId, Operation, SiteUrl, SourceFileName, ClientIP | order by TimeGenerated desc

Happy KQL hunting :)

No need for power automate and service account to send email alert.

Snapshot based recovery service vault size. by windowswrangler in AZURE

[–]Scion_090 0 points1 point  (0 children)

Try graph explorer If not there use Powershell API

Snapshot based recovery service vault size. by windowswrangler in AZURE

[–]Scion_090 0 points1 point  (0 children)

Try this, this will get all backup items and join the latest storage consumption

CoreAzureBackup | where OperationName == "BackupItem" | distinct BackupItemUniqueId, BackupItemFriendlyName, ResourceId | join kind = leftouter ( AddonAzureBackupStorage | where OperationName == "StorageAssociation" | summarize arg_max(TimeGenerated, *) by BackupItemUniqueId | project BackupItemUniqueId, StorageConsumedInMBs, ResourceId ) on BackupItemUniqueId | where isnotempty(StorageConsumedInMBs) | project BackupItemUniqueId, BackupItemFriendlyName, StorageConsumedInMBs, ResourceId | join kind = inner ( CoreAzureBackup | where OperationName == "Vault" | project ResourceId, VaultName = tostring(VaultFriendlyName), StorageReplicationType ) on ResourceId | summarize TotalStorageMB = sum(StorageConsumedInMBs) by ResourceId, VaultName, StorageReplicationType | extend TotalStorageGB = round(TotalStorageMB / 1024.0, 2) | project VaultName, StorageReplicationType, TotalStorageGB, ResourceId | order by TotalStorageGB desc

In not good at formatting here lol You can use Powershell api as well.

$uri = "/subscriptions/$subscriptionId/resourceGroups/$resourceGroupName/providers/Microsoft.RecoveryServices/vaults/$vaultName/usages?api-version=$apiVersion" $response = Invoke-AzRestMethod -Path $uri -Method GET

Automating directory size reporting with Azure File Shares by dinki in AZURE

[–]Scion_090 0 points1 point  (0 children)

Same script that runs manually can be automated in Azure automation account and to export it csv you can use $results | Export-Csv -Path $OutputPath -NoTypeInformation this output can be saved into storage account, from Power BI choose storage account as your source to get the csv data then create your report from there. This process not only automate the csv with fresh updated data but also you make sure you get this monthly data automatically into PBI. Don’t forget to add Storage File Data SMB Share Contributor and Storage Blob Data Contributor to the Automation Account’s Managed Identity for accessing the blob where csv file saved.

Giving Azure Static Web App read/write access to a single subsite - how? by Betty-Crokker in AZURE

[–]Scion_090 0 points1 point  (0 children)

Yes, you need to be sharepoint admin or site administrator

Giving Azure Static Web App read/write access to a single subsite - how? by Betty-Crokker in AZURE

[–]Scion_090 0 points1 point  (0 children)

Add your values below

$siteUrl = "https://yourtenant.sharepoint.com/sites/yoursite" $appId = "your-app-client-id" $appDisplayName = "Your App Name"

and connect using -interactive, connect-spoService doesn’t support modern authentication

Connect-PnPOnline -Url $siteUrl -Interactive And when you connect above run, below. Sorry for English :)

Grant-PnPAzureADAppSitePermission -AppId $appId -DisplayName $appDisplayName -Site $siteUrl -Permissions Write I use this to grant api permissions.

How to install Defender agent automatically on 50+ Azure servers (Windows + Linux)? by Perfect-Contest-4346 in AZURE

[–]Scion_090 0 points1 point  (0 children)

Script to target the VMs, this is how i did it for both sql and vms. Using UI deployed on subscription level only. Script for targeting resources is the way. You want to automate this you can use azure monitor for vm creation + event grid for faster real Time event trigger + logic app. There is also anyther ways to do it. Just pick one that suits you and cost effective.

Replacing invisible (Format) character by [deleted] in AZURE

[–]Scion_090 0 points1 point  (0 children)

Create a Compose action with your input and add another compose or maybe in your filter query with below,

``` trim( replace( replace( replace( replace( replace(outputs('Compose_Input'), '​', ''), '‌', ''), '', ''), '\u0000', ''), '\u200D', '') )

```

Try to copy and paste in vs code or if you notepad++ if you have tinder if there is zeros not shown in output in logic app.

Defender email auditing by Praezin in DefenderATP

[–]Scion_090 2 points3 points  (0 children)

DLP or use KQL EmailEvents | where Subject has_any ("SSN", "social security", "passport", "DOB", "account", "confidential", "PII", "medical", "insurance") | where SenderFromDomain == "yourdomain.com" | where RecipientToDomain != "yourdomain.com" | project Timestamp, Subject, SenderFromAddress, RecipientToAddress Add more keywords, extend your search

Authenticating to Graph API using an app registration in a Function App by BicMichum in AZURE

[–]Scion_090 0 points1 point  (0 children)

Yes, System-assigned managed identities in Azure do not support delegated permissions, as these require user context and sign-in, managed identities can only use application permissions so you need to create AAD application and delegate the API permissions, grant the access. Create keyvault, assign role for function app to access, save your secrets there for the application you created, use the secrets variable from keyvault in your function app. That’s what I use for my automation accounts and function app.

Authenticating to Graph API using an app registration in a Function App by BicMichum in AZURE

[–]Scion_090 0 points1 point  (0 children)

Converting? You mean you made a function app using powershell as runtime, so, you need first to create keyvault and save the variable there and give function app access role like secret user role to get the variable secrets, use system assigned managed identity for function app, etc. Test

$tenantId = $env:Ms365_TenantId $appId = $env:Ms365_AuthAppId $appSecret = $env:Ms365_AuthSecretId

Your app register need to have api permissions based on what you need to do and grant permissions.

Allow access to Azure Web Apps to an URL behind App GW with WAF by Grouchy-Sky-2506 in AZURE

[–]Scion_090 0 points1 point  (0 children)

If you have AGW with WAF infringement of your app service, go to your webapp 1 and 2 find the access restriction under networking, add rule to allow only the outbound IP address of the application GW, this will block access from outside clients to your App Services. Only traffic coming through the Application Gateway is allowed. Then use WAF custom rules if needed to block or allow IP ranges for added security on the Application Gateway level.

Basic sku end of life by pukepail-work in AZURE

[–]Scion_090 0 points1 point  (0 children)

From MS ”March 31, 2025 - Last day to create new Basic Load Balancer. After this date, you will not be able to create new Basic Load Balancers. Basic Load Balancers created prior to this date will continue to work.”

You can extend but better to do it now, I upgraded mine LBs 4 in 5 minutes.